2. Quick Start

This section demonstrates how to use the cellXpress to view a set of images, such as that obtained from a multi-well plate experiment, and extract data for individual cells in the images. A number of example projects are provided with the cellXpress package. In the following workflow, we will use one of these to show how to explore a dataset of multi-channel fluorescence images and extract high-content single-cell data:

  1. Start the cellXpress and load an existing project
  2. Browse and select a set of wells to work with
  3. Identify and segment individual cells in images
  4. Extract high-content features for individual cells
  5. Visualize the results for a plate or experiment

2.1. Starting the cellXpress

After installing cellXpress, double-click on the cellXpress icon on the desktop, or locate and run the program "C:\Program Files\cellXpress pro\cX_gui.exe".

images/Ch2_open-cX-icon.png
images/Ch2_open-cX.png

2.2. Loading an existing project

A cellXpress project provides a structure that links the different types of data in an image-based experiment:

  • Raw data: Image files stored in a hierarchical directory structure, i.e. Plate (top-level directory) > Well (sub-directory) > Frame/field (individual image files)
  • Intermediate/processed data: Various kinds of data generated by processing or analysis of the source images
  • Configuration files: Settings used for data processing or analysis

Here, we will open an example project included with the cellXpress package:

  • [cellXplorer]: Project>Open existing project.
  • Select the project directory "C:\Program Files\cellXpress pro\example\projects\121119-Drosophila_kc167".
  • The cellXpress project named "121119-Drosophila_kc167" will be loaded in the main cellXplorer window.
images/Ch2_open-existing-project.png

2.3. Selecting wells and viewing images

To work with image data in a project, we first need to select the wells in a plate that contain the images of interest. The cellXplorer window shows the plate structure as a 96- or 384-well grid (1: Plates). Selecting and adding wells to the Well List manager allows you to mark them for later analysis.

  • [cellXplorer]: To automatically select all the available wells in a plate, click on "Auto select wells" in the Well list panel. Selected wells will be highlighted.
  • [cellXplorer]: Alternatively, click on individual wells to select or deselect them. To select/deselect an entire row or column, click on the corresponding column or row button.
  • [cellXplorer]: In the Well list panel, click "+ Wells" to add the selected wells to the project’s well list.
  • [cellXplorer]: To view images from the selected wells, click on the "View" button in the Toolbar.
images/Ch6_cellXplorer.png
images/Ch2_auto-select-wells.png
images/Ch2_view-image.png

2.4. Cell segmentation

The next step is to identify individual cells in the images by performing segmentation. A set of default parameter values are provided, which can be tuned as needed to improve the segmentation results. The cellXpress enables you to adjust these parameters interactively, by previewing the effects of any changes made before performing segmentation in batch.

To adjust segmentation parameters

  • [cellViewer]: Analysis>Configure segmentation.
  • [cellViewer]: In the cellViewer "Channels" panel, select the check-boxes "Show cell outlines" and "Show region outlines" to show the segmentation outlines.
  • [cellViewer]: Adjust the parameters, then click "Apply and test configuration" to preview the effects of your changes on the segmentation output.
  • [cellViewer]: Once you are satisfied with the results, click "Save" and "Close" to save the modified settings.
  • [cellViewer]: File>Close.
images/Ch2_tune-segment-parameter.png

To perform segmentation on selected wells

  • Select one or more wells for processing.
  • [cellXplorer]: Profiling>Segment cells for the selected wells
  • When the segmentation process is completed, you will see the message "Done!" in the Log panel.
images/Ch2_run-segmentation.png

To view the segmentation results

  • [cellXplorer]: Select one or more wells to view, then click on the "View" icon in the Toolbar.
  • [cellViewer]: In the cellViewer "Channels" panel, toggle the check-boxes "Show cell outlines" and "Show region outlines" to show/hide the segmentation outlines.
images/Ch2_view-segmentation-results.png

2.5. Feature extraction

After segmenting the cells in the images, the next task is to decide on the features required and perform feature extraction. By default, the "Basic" setting is used. This will extract the most commonly used features for the whole-cell and nuclear regions. Additional features and regions can be selected as shown below.

After extracting the features, you can view the feature values for individual cells alongside the original images, or look at a graphical summary of the feature data for the whole plate.

Set options for feature extraction

  • [cellXplorer]: Markerset>Settings>Feature and region types
  • [Feature panel]: Feature type: Basic ON for all channels
  • [Feature panel]: Region type: Whole cell ON for all channels
  • [Feature panel]: Region type: Region type: DNA region ON for all channels
  • [Feature panel]: Click "OK" to accept settings
images/Ch2_setting-feature-types.png
images/Ch2_feature-type-selection.png

Perform feature extraction

  • [cellXplorer]: Profiling>Extract features from the selected wells
  • When the feature extraction process is completed, you will see the message "Done!" in the Log panel.
images/Ch2_run-feature-extraction.png

Visualize the features extracted for individual cells

  • Select one or more wells and click to "View" in the cellViewer.
  • [cellViewer]: In Channels panel, check the boxes "Show cell outlines" and "Show region outlines" to display the cell and region boundaries.
  • [cellViewer]: Analysis>Show feature values
  • [cellViewer]: Select a specific feature to display, e.g. "Area of cell region", then click "OK" to accept the settings.
  • [cellViewer]: To view the extracted feature values for individual cells, move the mouse pointer over the cells of interest. The individual cell’s identifier (cellID) and its feature values are shown at the lower left of the cellViewer window.
images/Ch2_configure-cell-labels.png
images/Ch2_feature-values-displayed.png

2.6. Cell counting

The cell counting tool computes the total and mean number of cells identified from the images for each well and displays the result for all the wells in the plate graphically. This function is only available after cell segmentation and feature extraction have been performed.

  • [cellXplorer]: Analysis>Count cells
images/Ch2_cell-count.png

2.7. Analyze intensity

The intensity analysis tool provides a quick graphical summary of the intensity features for the selected plate. This function is only available after cell segmentation and feature extraction have been performed. Using the Results menu, you can select a feature to display. For each feature, the mean values for the well are shown as a color map, with numerical values shown in the side-bar. An "X" in a well indicates that no data is available for that well. The intensity analysis results can be saved in graphical or compressed numerical data format.

  • [cellXplorer]: Analysis>Analyze intensity
  • [intensity analysis]: Use the Results menu to change the feature being viewed
  • [intensity analysis]: Use File>Save as to save the analysis results
images/Ch2_plot-intensity-distribution.png